관리 메뉴

The Spotless Mind

테터, 리퍼러 오류 도와주세요 본문

NOTE

테터, 리퍼러 오류 도와주세요

아리스노바 2006.07.10 23:41
1.0.4버전에서 모르고 1.0.5버전에서 사용되는 플러그인을 사용해서

에러로 깨진걸, 복구하고 제가 1.6인줄 알고 있다가 아닌걸.. 확인 하는 바람에
업그레이드를 했습니다.

업그레이드를 하면 파일이 덮어쓰기가 됐을텐데 그래도 에러 메세지가 뜨네요.
무엇이 문제인지 모르겠어서 질문합니다.

-에러메세지



설치했던 플러그인입니다.
http://www.gmong.com/entry/태터툴즈-1020-리퍼러-로그-제대로-보이게


저 때문에 신경 써주신 gmong님 감사합니다.
6 Comments
  • 프로필사진 BlogIcon gmong 2006.07.10 23:47 위 내용중 requirecomponent(/components/Eolin.PHP.Core.php): 를 보시면
    경로 지정이 잘못되어 있습니다. ../../../..//components/Eolin.PHP.Core.php 이런식으로 되어야하는데요.

    referer/index.php 의 내용중 25~29번째줄 내용이
    function requireComponent($name){
    if(!ereg('^[[:alnum:]]+[[:alnum:].]+$',$name))
    return ;
    include_once ("../../../../components/$name.php");
    }
    이런 함수가 있는지요?
  • 프로필사진 BlogIcon 아리스노바 2006.07.10 23:50 function requireComponent($name){
    if(!ereg('^[[:alnum:]]+[[:alnum:].]+$',$name))
    return ;
    include_once ("/components/$name.php");
    }

    이런식으로 되어있군요. 경로가 잘못된건가요?
  • 프로필사진 BlogIcon gmong 2006.07.10 23:54 제 블로그(1.0.6.1)에 1.0.5 파일 덮어 쓰니깐 잘 나오긴 하네요;; 뭔가 다른 문제가 있을 수 있겠군요.
    ( 덮어쓴 후 스샷 : http://www.gmong.com/test.gif )

    아리스님,
    include_once ("/components/$name.php");
    이 부분을
    include_once ("../../../../components/$name.php");
    이렇게 바꾸어보세요.
  • 프로필사진 BlogIcon 아리스노바 2006.07.10 23:58 정상적으로 나오네요. 정말 감사드립니다. _ _

    6으로 업그레이드 하면 그 플러그인은 사용할 수 없는건가요?
  • 프로필사진 BlogIcon gmong 2006.07.11 00:11 지금 제 블로그에 깔아놓고 써봤는데 별 무리는 없으나, 혹시 모르니 원래 파일은 다른 이름으로 바꾸어 놓으셔서 백업해두시는게 나을듯 합니다.
    정상적으로 되었다니 다행입니다 :)
  • 프로필사진 BlogIcon 아리스노바 2006.07.11 00:15 네-! 이젠 백업을.. 생활화 ^^;
    수고하셨어요. 감사합니다. ^^
댓글쓰기 폼